this website is designed for the first (and still the best) multiplayer version of Far Cry

you will find all informations about the Far Cry Community Patch 1.6

if you still have questions, feel free to contact us


introduction

What is it? Another new version, you might think. Well it is not just a new version.

installation

1. Install the official patch 1.4 of Ubisoft. This is needed – otherwise the Patch 1.6 will not work.

f.a.q.

Can I play 1.6 on Windows 7-10 (64bit)?

After UbiSoft closes their regserver for Far Cry 1 in October 2016, it's not possible to play 1.6 multiplayer anymore. If you want to play 1.4 multiplayer please use the LR Addon!

LR Addon